WMWARE Player 15.5 업데이트가 떠서 업데이트를 하려고 했더니 이상한(?) 메세지와 함께 설치가 안됩니다.

alert창에 Html 링크를 달아두었으나 작동하지 않아서, 웹브라우저 주소창에 http://kb.vmware.com/kb/55798 입력하고 확인 해 봅니다.

 

 

 

 

 

 

https://kb.vmware.com/s/article/55798 이동하니... 영어로 뭔가 말이 많은데, 결론은 "Microsoft Visual C++ 2017 Redistributable "가 사전 설치 되어 있어야 한다는 내용입니다.

 

 

 

 

 

 

 

 

 

 

 


VMWARE KB에 있는 링크는 도움이 되지 않았고.... 구글 에서 "Microsoft Visual C++ 2017 Redistributable"를 검색해서 다운 로드 설치합니다.

The latest supported Visual C++ downloads
Visual Studio > 기타 도구 및 프레임 워크 > Visual Studio 2019용 Microsoft Visual C++ 재배포 가능 패키지

위 2개의 링크 자료 모두 파일명과 용량이 같습니다.

 

 

 

 

 

 

 

재부팅 할 필요가 없다는 것은 훼이크인가?? -_-? 어쨌든 재부팅 한번 해주고...

 

 

 

 

 

 

 

 

 

 


VMWARE Player 업데이트를 하면.....

 

 

 

 

 

 

 

 

 

 

 

업데이트 완료!



한줄 요약


VMWARE Player 15.5 업그레이드 시 "Microsoft VC 재배포 가능 패키지 설치" 메세지가 나오면, 가장 최근의 "MS VC++ 재배포 가능 패키지"를 설치하자.




어려움을 딛고 윈도우 18342.8 (19h1_release) 업데이트 이후 뱅킹용으로 쓰던 VMWARE 윈도우즈 이미지에 문제가 발생했는데

그것은 바로 게스트 OS가 윈도우 일때 "BLACK SCREEN"이 발생 한다는 것. 그런데 심심해서 설치해둔 리눅스 이미지는 매우 잘 돌아간다.

각각의 마지막 작업을 확인하면
게스트 OS 가장 마지막 작업이 "AhnLab Safe Transaction" 업데이트
호스트 OS 가장 마지막 작업이 윈도우 18342.8 (19h1_release) 업데이트

흐음...... 그럴리는 없는데... 자꾸... 의심이 가는것은 어쩔수가 없다.


증상



- 인사이더 업데이트 후 VMWARE Player 14 버전에서 최초 발생 했는데, VMWARE Palyer 15 버전으로 업데이트 해도 동일한 증상 발생
- VMWARE Player 15에서 화면 설정을 "Specify monitor setting"으로 해상도 설정 후 딱 1번 정상 부팅되고, 이후 계속 블랙 스크린이 발생했다.
- 이때 절전 모드, 전원 종료, 재시작등의 명령이 하나도 안 먹는다. 다시 실행볼 수 있는 유일한 방법은 메인 컴퓨터( 호스트 컴퓨터 ) 재부팅 해야 했다.


주요 참고 게시글 : Workstation Pro 14 VM for Windows 10 has blank screen


일단 화면을 띄워야 한다!





사실 검정 화면만 보이다가, 왜 화면이 떴는지 잘 모르겠다.
3D Graphic, 스케일링 사용 유/무는 영향이 없었고 "모니터 설정"을 바꾸니 떴다. 이게 다음번에도 유요할지는 잘 모르겠다는것은 함정....


어쨌든 유일(?)할지 모르는 기회이기 때문에 바로 안전 모드로 부팅하고, VMware SVGA 3D 드라이버를 삭제 하고 재부팅...
( 참고한 링크의 덧글과는 다르게 안전모드에서 VMware Tool Service 는 실행되지 않고 있었다. )

재부팅 후 디스플레이 어댑터를 확인 해보니 VMware SVGA 3D 드라이버 대신, "Microsoft 기본 디스플레이 어댑터"로 잡혀 있는 것을 확인 할 수 있다.

이 상태에서 절전 모드, 재부팅, On/off 테스트를 해보니 문제 없이 잘 된되지만, 제대로된 해상도를 사용할 수 없고 화면이 매우 느리기 때문에 드라이버 설치를 해야 한다.




VMware SVGA 3D 드라이버 설치는 VMware Tools 제거 후 재설치를 하면 끝





이 와중에도 눈에 띄어 스트레스를 주는 저 "AhnLab Safe Transaction" 아이콘을 보라!








안전 모드에서 VMware SVGA 3D 드라이버를 삭제하고 부팅하면 "Microsoft 기본 디스플레이 어댑터"로 잡혀 있다.
이를 VMware SVGA 3D 드라이버로 바꾸기 위해서는 기존 설치된 VMWARE Tools를 제거 후 재설치를 하면 된다.


다행이도 새로 설치한 이후에는 아직까지 "Black Screen" 문제가 발생하지 않고 정상적으로 부팅되고 있다.

결국 앞서 의심한것과는 다르게 "VMWARE SVGA 3D 드라이버" 문제라고 추정할 수 있을 것 같은데, 해결 방법이 일단 화면이 떠야 뭐를 할 수 있다는게 제일 큰 문제다.

나중에 유사한 문제가 발생했을 때 이와 같은 방법으로 해결할 수 있을지는 모르겠지만, 어쨌든 정리를 위해 포스팅



윈도우 인사이더 패스트링의 잦은 업데이트가 귀찮아서 슬로우링으로 바꿔놓은 후 오랜만에 업데이트가 등장했습니다.





문제는 업데이트가 완료되지 않는 다는 것!!






윈도우 피드백 허브를 통해 간단히 리포트를 해주고난 후 검색을 해보니 윈도우 디펜더를 끄고 업데이트가 되었답니다.;;;;





해당 답변 링크







윈도우 디펜더 관련 항목을 모두 끄고, 업데이트 시작








깔끔하게 업데이트 완료!

아니 다른 업체 프로그램도 아니고, 윈도우 자체 프로그램때문에 업데이트 설치가 안되다니......

패스트링일때는 경험하지 못한것을 슬로우링에서 경험하다니... OTL



iOS 11.4 업데이트 이후 아이폰6S의 박대리가 미친듯이 퇴근한다!!!






아이폰6S는 순전히 뱅킹용으로만 사용하고 파우치에 항상 들어가 있기 때문에 대기 시간이 널널해야 합니다.
하지만 iOS 11.4로 올리고 나니 아이폰 6S는 박대리가 미친듯이 퇴근해 버리는 문제가 발생!!! 웃기게도 같은 11.4로 업데이트 한 아이패드 프로는 전혀 문제가 없다는 사실!


일단 백그라운드 프로세스가 문제인 것으로 보고 백그라운드 앱 새로고침 자체를 차단 합니다.
이후 계속해서 백그라운드 앱 새로그침은 차단 상태로 확인.








3시간만에 40%가 날라가버리는............웃기게도 실제 실행 시간은 안습일 정도로 적은 시간...
"블루투스가 문제 일 수도 있다" 라는 후배의 말에 따라, 완충 후 블루투스를 끄고 확인 해 봐도 동일한 문제 발생








저전력 모드를 사용해도 박대리 퇴근 시간에는 큰 차이가 보이지 않습니다.
그래서 비행기 모드를 설정해보니 박대리가 빨리 퇴근 하지 않는 다는 점을 발견!









비행기 모드는 무선 통신 상태를 끄기 때문에, LTE Only 와 LTE + WIFI 두개를 확인 해 보기로 합니다.

우선 LTE만 켠 상태에서는 7시간 동안 3% 사용했고, WIFI를 켜니 2시간만에 14% 사용합니다.
















그래서 WIFI를 끄고 LTE만 연결한 상태에서 테스트 해보니 약 8시간 후에 1%가 소모되고, 45시간을 써도 26%가 소모되는 기이한 현상이.....


최고 수준의 하드웨어&소프트웨어 퀄리티를 자랑하는 애플 이잖아?

성능 제한으로 까이고 나서 이제는 WIFI로 배터리 장난질을 치는건 아니겠지???

그냥 내가 가진 아이폰6S가 오래된 기기라서 단순 오류 or 내 기기가 이상하기만을 바랄뿐이다.


그래서 다음 업데이트는 언제인게냐??


  1. 세츠나 2018.11.19 22:12

    소중한 후기 감사합니다. 배터리드레인 관련 검색하다가 들어오게됐네요. 옛날에는 통상lte상태에서 더 빠르게 배터리가 닿았는데, 요샌 어쩐지 와이파이 상태에서도 빨리 닿는다했더니.. 이런 팩트체크가 있어서 반갑고 놀라웠습니다. 과연 진실은 무엇일지... ㄷㄷㄷ

bitnami 사용 시 문제점은 내가 직접 설치했을 때 일반적으로 적용되는 파일 위치가 조금씩 다르다는 점. 

따라서, 에러가 발생하게 되면 일단 당황하기 시작하는데.... 



일단 시작은 error 메세지 확인 부터 시작


"The Phusion Passenger application server encountered an error while starting your web application" 이란다...


가장 기본적인 아파치 로그 확인해보니...... 로그 크기가 "0"임 -_-;;;;


/var/log/apache2




???? Why???  Log 파일은 어디있지?????


이때부터 멘붕.. 당황.... 짜증의 삼박자! -0-


여기까지 찾아오신 분들 당황하지 마시고....


1. 웹페이지에서 에러 메세지 확인


- 아파치가 구동되는 상황이기 때문에,  Phusion Passenger의 에러 메세지 표시 활성화

- /opt/bitnami/apps/redmine/conf/httpd-app.conf 에 "PassengerFriendlyErrorPages on" 추가




2. 에러 메세지 확인 후 조치 실행



결론은 redmine 플러그인 설치 시 에러가 발생했던 부분 때문에 접속이 안되었던것으로, bundle install을 통해 해결 완료

( 플러그인 당시에는 문제가 없다가.... 왜 나중에서야 문제가 발생했던 것이냐!! ㅜ.ㅜ)


참고로 bitnami apache2의 로그는 "/var/log/apache2" 아 아니라 "/{installdir}/apache2/logs" 경로에 있다. 


내 경우 "/opt/bitnami/apache2/logs" 에 위치... 따라서 /var/log/apache2에서 뒤져봐야 안나오는 것은 당연.....


참고로 bitnami Phusion Passenger관련 로그는 아래 경로에 있다. 


/opt/bitnami/apps/redmine/htdocs/log/production.log


쉽게 해결할 수 있는 것을 경험 부족 ( 근데...나 기획자인데.... OTL) 으로 시간이 오래 걸리게 되어 버리는.....


어쨌든 해결 완료!


2017.01.20 logs 위치


/home/bitnami/apps/redmine/htdocs/log









+ Recent posts